Return

Description

The Zyxel GS1900-24E managed switch, in black, connects your network with 24 Gigabit Ethernet RJ-45 (10/100/1000) copper ports. It supports the IEEE 802.1p, 802.3, 802.3ab, 802.3az, 802.3u and 802.3x standards, and works with 1000BASE-T, 100BASE-T and 10BASE-T cabling technologies. It offers quality of service (QoS), flow control, rate limiting and storm transmission control to manage traffic. In terms of security, it filters MAC addresses and supports 802.1x RADIUS along with SSH and SSL. Its management is based on SNMP v1, v2 and v3, RMON (1, 2, 3, 9) and the RFC 1213 MIB II, RFC 2819, RFC 1215 and RFC 1493 MIBs. It complies with the LVD EN60950-1 and BSMI CNS14336-1 safety standards. A piece to deploy a 24-port wired network with centralised management.

Specifications

Management features


  • Switch type: Managed
  • Quality of Service (QoS) support: Yes
  • MIB support: RFC 1213 MIB II, RFC 2819, RFC 1215, RFC 1493

Ports & interfaces


  • Basic switching RJ-45 Ethernet ports quantity: 24
  • Basic switching RJ-45 Ethernet ports type: Gigabit Ethernet (10/100/1000)
  • Gigabit Ethernet (copper) ports quantity: 24

Network


  • Networking standards: IEEE 802.1p, IEEE 802.3, IEEE 802.3ab, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x
  • Copper ethernet cabling technology: 1000BASE-T, 100BASE-T, 10BASE-T
  • Flow control support: Yes
  • Broadcast storm control: Yes
  • Rate limiting: Yes

Security


  • Security algorithms: 802.1x RADIUS
  • MAC address filtering: Yes
  • SSH/SSL support: Yes

Protocols


  • Management protocols: SNMP v1,v2,v3, RMON (1,2,3,9)

Design


  • Product colour: Black
  • Safety: LVD EN60950-1, BSMI CNS14336-1

Power over Ethernet (PoE)


  • Power over Ethernet (PoE): No

Certificates


  • Certification: CE, FCC, C-Tick, Class A (GS1900-8HP/24/24HP/48/48HP) CE, FCC, C-Tick, Class B (GS1900-8/16/24E) BSMI CNS13438

Similar products

Zyxel GS1900-8 Managed L2 Gigabit Ethernet (10/100/1000) Black
Few units left

Zyxel GS1900-8 Managed L2 Gigabit Ethernet (10/100/1000) Black

56.86 €

Get it on the October 7 / on the October 8
-9%
Zyxel GS2220-28HP-EU0101F network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black
Few units left

Zyxel GS2220-28HP-EU0101F network switch Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black

407.47 € 446.32 €

Get it on the October 7 / on the October 8
Trendnet TI-G160i Managed L2 Gigabit Ethernet (10/100/1000) Black
Few units left

Trendnet TI-G160i Managed L2 Gigabit Ethernet (10/100/1000) Black

407.47 €

Get it on the October 7 / on the October 8
D-Link 12-Port L2 Managed Switch Switch with 8 x 10/100/1000BaseT(X) & 4 x 100/1000BaseSFP
Few units left

D-Link 12-Port L2 Managed Switch Switch with 8 x 10/100/1000BaseT(X) & 4 x 100/1000BaseSFP

906.86 €

Get it on the October 7 / on the October 8
-20%
Zyxel GS1915-24EP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Black
Few units left

Zyxel GS1915-24EP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Black

204.68 € 256.80 €

Get it on the October 7 / on the October 8
-10%
Zyxel RGS200-12P Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black
Few units left

Zyxel RGS200-12P Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black

986.46 € 1,096.38 €

Get it on the October 7 / on the October 8
TP-Link TL-SG1024 network switch Unmanaged L2 Gigabit Ethernet (10/100/1000) Black

TP-Link TL-SG1024 network switch Unmanaged L2 Gigabit Ethernet (10/100/1000) Black

89.07 €

Get it on the October 7 / on the October 8
-9%
Zyxel GS1900-24 Managed L2 Gigabit Ethernet (10/100/1000) Black
Few units left

Zyxel GS1900-24 Managed L2 Gigabit Ethernet (10/100/1000) Black

124.14 € 136.45 €

Get it on the October 7 / on the October 8
Zyxel GS2220-50-EU0101F network switch Managed L2 Gigabit Ethernet (10/100/1000) Black
Few units left

Zyxel GS2220-50-EU0101F network switch Managed L2 Gigabit Ethernet (10/100/1000) Black

532.55 €

Get it on the October 7 / on the October 8

User Comments

Share your opinion with other users.

No comments yet. Be the first!

The best prices.

The best prices.

The most competitive prices on the market.

100% guaranteed shipping.

100% guaranteed shipping.

The best logistics system for high demand.

Returns up to 30 days.

Returns up to 30 days.

Return policy tailored to your needs.

Over 10 years of experience.

Over 10 years of experience.

A long track record backs us, with great experience in the industry.